Performance Issues
Incident Report for Azuqua
Resolved
Our tests show the performance issues have been successfully resolved. FLO performance was degraded for some customers from March 9 10:27 PM PST to March 10 7:20 AM PDT (March 10, 05:27 AM UTC to 03:20 PM UTC); see how do performance issues impact different types of FLOs?.

Additionally as part of mitigating the performance issues, at 12:12 AM PST (8:12 AM UTC) Azuqua Tables data was restored to a backup from March 9 10:27 PM PST (March 10 5:27 AM UTC). Any additions, modifications, or deletions to data in an Azuqua Table during that time period were undone. To avoid additional data integrity issues, we will not be automatically restoring changes from the affected time period. We will reach out to impacted customers to assist with manual restoration if required.
Posted Mar 10, 2019 - 19:26 PDT
Monitoring
We believe we've identified and fixed the issue. Performance should be fully back to normal. We are monitoring the system and will remove this alert once we've confirmed there are no new performance issues
Posted Mar 10, 2019 - 05:30 PDT
Update
We are continuing to investigate this issue.
Posted Mar 10, 2019 - 03:27 PDT
Update
We are continuing to investigate this issue.
Posted Mar 10, 2019 - 01:50 PST
Investigating
We are currently experiencing a heavy execution load. All FLOs are executing but the system may appear sluggish while we increase our capacity. How do performance issues impact different types of FLOs?
Posted Mar 10, 2019 - 00:36 PST
This incident affected: FLOs Running (Monitor FLOs, Real Time and API Endpoint FLOs, Scheduled FLOs, Other), Developer Platform (Azuqua API, Connector Builder), and Website (Viewing, Editing, and Saving FLOs, FLO History, Other).