Service Disruption
Incident Report for Azuqua
Postmortem

On August 30th 2019, at approximately 10:56 AM PDT Azuqua received reports from some customers of API endpoint failures.

Upon investigation, Azuqua determined that a cache store linked to Flow executions had become unavailable at 10:34 AM PDT due to an underlying infrastructure failure. This prevented Flows from executing for the duration of the incident.

At approximately 11:02 AM PDT the store became available again as the issue with the third party was fully resolved and the service was fully restored automatically.

Okta is implementing additional monitoring and alerting to further enhance detection of similar errors in the future. We are also implementing an automatic failover of this cache so that in case of a future issue such as this, the failover happens automatically and causes minor to no disruption.

Posted Sep 03, 2019 - 17:39 PDT

Resolved
This incident has been resolved.
Posted Aug 30, 2019 - 13:03 PDT
Monitoring
An issue impacting Flow executions from 10:30am to 11:02am PDT (5:30 to 6:02pm UTC) has been identified and fixed. Service has been restored to normal. Additional root cause information will be provided within 48 business hours. What happens to Flows during an outage?
Posted Aug 30, 2019 - 11:45 PDT
This incident affected: FLOs Running (Monitor FLOs, Real Time and API Endpoint FLOs, Scheduled FLOs, Other), Developer Platform (Azuqua API, Connector Builder), and Website (Viewing, Editing, and Saving FLOs, FLO History, Other).