Folder Permissions Issue
Incident Report for Azuqua
Resolved
On Oct 7th at approximately 1:30pm PDT, customers reported missing flows in their folders when using the Designer.

Upon investigation, Okta determined that the issue was caused by a bug introduced on Oct 2nd that impacted user permissions in accessing flows, tables, and connections under some shared folders.

When a user belonging to multiple organizations was removed from a single organization, the entire set of permissions to any assets (i.e. flows, tables, connections) in the shared folders were impacted, which made some of these assets inaccessible to other users with access to the shared folders.

On Oct 8, Okta began to roll back the software change to the previous release version, and applied a fix to restore permissions for folders and flows that were affected.

Okta is implementing automated testing for multi-org scenarios and developing automation to verify permissions across all resources for all customers.
Posted Nov 18, 2019 - 16:50 PST
Update
We are continuing to work on our root cause investigation and mitigation activities. We will provide our next update no later than November 18 @ 5:00pm PST.
Posted Nov 11, 2019 - 17:31 PST
Update
We are continuing to work on our root cause investigation and mitigation activities. We will provide our next update no later than November 11 @ 5:00pm PST.
Posted Nov 04, 2019 - 17:00 PST
Update
We are continuing to work on our root cause investigation and mitigation activities. We will provide our next update no later than November 4 @ 5:00pm PST.
Posted Oct 29, 2019 - 16:30 PDT
Update
We are continuing to work on our root cause investigation and mitigation activities. We will provide our next update no later than Oct 29 @ 5:00pm PST.
Posted Oct 22, 2019 - 18:33 PDT
Update
We are continuing to work on our root cause investigation and mitigation activities. We will provide our next update no later than Oct 22 @ 5:00pm PST.
Posted Oct 18, 2019 - 16:37 PDT
Update
We are continuing to work on our root cause investigation and mitigation activities. We will provide our next update no later than Oct 18 @ 5:00pm PST.
Posted Oct 16, 2019 - 15:36 PDT
Update
We are continuing our root cause analysis investigation and long-term mitigation and future preventative actions. We will provide our next update no later than Oct 15, 2019 @ 5:00pm PST.
Posted Oct 12, 2019 - 08:14 PDT
Monitoring
An issue preventing users from viewing and editing flows inside folders has been resolved. We identified the underlying cause of the loss of folder permissions as a regression introduced during a recent release. We reverted the change and are currently working with impacted customers to validate the fix and monitoring for any further issues.
Posted Oct 08, 2019 - 17:06 PDT
Update
Due to a change in folder permissions some customers have lost the ability to view and edit flows inside folders. We have identified the underlying cause of the loss of folder permissions and are actively working to mitigate. We have reports that some flows are also failing and we are currently investigating.
Posted Oct 08, 2019 - 11:11 PDT
Update
We are continuing to investigate this issue.
Posted Oct 08, 2019 - 10:11 PDT
Investigating
Due to a change in folder permissions some customers lost the ability to view and edit flows inside folders. The flows continue to run and we are investigating the loss of folder permissions.
Posted Oct 08, 2019 - 10:11 PDT
This incident affected: Website (Viewing, Editing, and Saving FLOs).